Forum Jump: 
 8212Likes
Reply
 
Thread Tools
post #8311 of 8463 Old 12-26-2018, 10:43 AM
Member
 
no_cure's Avatar
 
Join Date: Jan 2007
Location: DFW
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Liked: 13
Quote:
Originally Posted by Ben Larkins View Post
Thanks @Evan201 . I know it's Christmas but I'm dying for any further advice here. My two factors between this and the 900f are the motion handling issues of the 940E vs the improved black levels off angle (40 degrees vs 12 degrees). I feel like I know for 100% certaint that if I get the 900F I'll see the washed out blacks more easily with the 12 degree off angle black level. But is it as certain that I'll see blur as easily if I get the 940E? I don't watch hockey at all. My understanding is the blur is only with 60fps objects on a white background? I game 25% of the time (switch, xbox) so what's the likelihood I'll be able to tell? Is it only with 60fps content?

Ugh, really tough christmas day choice. Same exact price on BB. I mainly sit in front of my TV but feel like the extra viewing angle (along with other perks of the 940E) help. Just that stinking motion handling I'm worried about for the 25% of time I play games with my kids and watch sports.

Bottom line, I feel like the viewing angle I could deal with, the motion blur I couldn't. But that's if there is any motion blur, while there definitely is a lack of a viewing angle on the 900f.
I was in the same boat only 2 weeks back: I chose the 940E for its stellar HT/dark room/movie capabilities. The blacks are BETTER than my Panny Plasma (still going strong), and haven't noticed any motion blur issues (I have my setting to SMOOTH).

Also, the 940E has a GAME setting as well, which will definitely help you when gaming...
MCaugusto and srkmish like this.
no_cure is online now  
Sponsored Links
Advertisement
 
post #8312 of 8463 Old 12-26-2018, 10:49 AM
Member
 
no_cure's Avatar
 
Join Date: Jan 2007
Location: DFW
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Liked: 13
I will say this though: perhaps it could be 9+ years of being 'adjusted' to the ways of how the Panasonic Plasma rendered colours, but I find the colour on the 940E to be too green and not as 'vivid'. Contrast ratio, clarity, etc - 5 stars stellar.

But the Panny was more pleasing to 'my eyes' colour wise...of course, I'm still playing with the settings
no_cure is online now  
post #8313 of 8463 Old 12-26-2018, 12:56 PM
Senior Member
 
Evan201's Avatar
 
Join Date: Jan 2017
Posts: 410
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 268 Post(s)
Liked: 176
Quote:
Originally Posted by no_cure View Post
I will say this though: perhaps it could be 9+ years of being 'adjusted' to the ways of how the Panasonic Plasma rendered colours, but I find the colour on the 940E to be too green and not as 'vivid'. Contrast ratio, clarity, etc - 5 stars stellar.

But the Panny was more pleasing to 'my eyes' colour wise...of course, I'm still playing with the settings
Probably could use a professional calibration to remove some of that green tint, but I'm just hesitant to spend what the pro calibrators are asking. I'd rather pick up my own calibration hardware/software for just above what they charge and start learning it myself. Very tempted.

CURRENT SETUP:
Sony X940E / Denon AVR-S730h /
NVIDIA SHIELD TV 2017 / PANASONIC UB820 UHD PLAYER / MAudio BX8a front mains / Klipsch R‑15PM rear left/right / Emotiva C1 center / Polk Audio OWM3 height left/right.
Evan201 is offline  
Sponsored Links
Advertisement
 
post #8314 of 8463 Old 12-26-2018, 09:12 PM
Senior Member
 
Evan201's Avatar
 
Join Date: Jan 2017
Posts: 410
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 268 Post(s)
Liked: 176
Ok guys,

The last few lines of pixels on the bottom and right side of my tv only when using the Netflix app via Nvidia Shield TV are showing up green. What the hell?
Nothing else has this problem. Only netflix app and I believe it only came to be after the recent Shield update. I checked the overscan is correct on the shield and adjusted all the way out to the edges. Any ideas?




CURRENT SETUP:
Sony X940E / Denon AVR-S730h /
NVIDIA SHIELD TV 2017 / PANASONIC UB820 UHD PLAYER / MAudio BX8a front mains / Klipsch R‑15PM rear left/right / Emotiva C1 center / Polk Audio OWM3 height left/right.
Evan201 is offline  
post #8315 of 8463 Old 12-27-2018, 08:10 AM
Member
 
no_cure's Avatar
 
Join Date: Jan 2007
Location: DFW
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Liked: 13
Quote:
Originally Posted by Evan201 View Post
Probably could use a professional calibration to remove some of that green tint, but I'm just hesitant to spend what the pro calibrators are asking. I'd rather pick up my own calibration hardware/software for just above what they charge and start learning it myself. Very tempted.
Thanks Evan - will look into it.
no_cure is online now  
post #8316 of 8463 Old 12-27-2018, 08:11 AM
Member
 
no_cure's Avatar
 
Join Date: Jan 2007
Location: DFW
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Liked: 13
Quote:
Originally Posted by Evan201 View Post
Ok guys,

The last few lines of pixels on the bottom and right side of my tv only when using the Netflix app via Nvidia Shield TV are showing up green. What the hell?
Nothing else has this problem. Only netflix app and I believe it only came to be after the recent Shield update. I checked the overscan is correct on the shield and adjusted all the way out to the edges. Any ideas?



That doesn't look 'kosher' to me. Is it on ALL Netflix shows, or just the Elen one?
no_cure is online now  
post #8317 of 8463 Old 12-27-2018, 08:21 AM
Member
 
no_cure's Avatar
 
Join Date: Jan 2007
Location: DFW
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Liked: 13
Quote:
Originally Posted by no_cure View Post
That doesn't look 'kosher' to me. Is it on ALL Netflix shows, or just the Elen one?
Netflix streaming via Sony app + Dolby Vision??

So I've got some weird issues via the Netflix app (via Sony's native streaming) while watching Dolby Vision shows, specifically Narcos Mexico. The show look HORRIBLE, the faces are oversaturated and pixulated, most dark scenes are showing banding (correct terminology??). But the worst part is this:

I'm not sure if I saw this or not in the earlier episodes, but in the latter ones (8-10) the scenes just seem to 'flicker' and seemingly change their own luminosity and tint (as if some gremlin is playing with the color temperature...changes from greenish, to bluish).

I then switched back to watching the remainder of the show via my Oppo 105D, and didn't have those weird picture issues. Sure, I've force the Oppo to upscale to 4K (not quite as good) but the blinking issue didn't occur at all.

Is this a Netflix streaming issue via native Sony or an HDR/DV issue? I'm not sure if I saw it in any other show (just finished Dogs of Berlin (just 4K resolution, not DV) and don't recall that.

Am I seeing things or has anyone else experienced this?

For my sanity, I appreciate the input!

Cheers!
no_cure is online now  
post #8318 of 8463 Old 12-27-2018, 08:24 AM
Member
 
no_cure's Avatar
 
Join Date: Jan 2007
Location: DFW
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Liked: 13
Quote:
Originally Posted by Evan201 View Post
Ok guys,

The last few lines of pixels on the bottom and right side of my tv only when using the Netflix app via Nvidia Shield TV are showing up green. What the hell?
Nothing else has this problem. Only netflix app and I believe it only came to be after the recent Shield update. I checked the overscan is correct on the shield and adjusted all the way out to the edges. Any ideas?



Try watching the same show/episode via Sony's native Netflix streaming app. If you don't have that green banding issue, it's the Nvidia then (I suspect as much)
no_cure is online now  
post #8319 of 8463 Old 12-27-2018, 10:41 AM
Senior Member
 
Evan201's Avatar
 
Join Date: Jan 2017
Posts: 410
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 268 Post(s)
Liked: 176
Quote:
Originally Posted by no_cure View Post
That doesn't look 'kosher' to me. Is it on ALL Netflix shows, or just the Elen one?
It shows up on all Netflix material from the Shield TV.
I got it to go away by changing the 940E "display area" setting to "normal" mode instead of "full pixel." I'm sure full pixel is best for full resolution, but the "normal" mode is satisfying enough I suppose.

CURRENT SETUP:
Sony X940E / Denon AVR-S730h /
NVIDIA SHIELD TV 2017 / PANASONIC UB820 UHD PLAYER / MAudio BX8a front mains / Klipsch R‑15PM rear left/right / Emotiva C1 center / Polk Audio OWM3 height left/right.

Last edited by Evan201; 12-27-2018 at 10:51 AM.
Evan201 is offline  
post #8320 of 8463 Old 12-27-2018, 10:50 AM
Senior Member
 
Evan201's Avatar
 
Join Date: Jan 2017
Posts: 410
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 268 Post(s)
Liked: 176
Quote:
Originally Posted by no_cure View Post
Try watching the same show/episode via Sony's native Netflix streaming app. If you don't have that green banding issue, it's the Nvidia then (I suspect as much)
Yea so just tried putting the "display area" setting back to Full Pixel and played the same thing on the native netflix app and don't see the green pixels anymore. Must be an issue with the Shield Netflix app only. Weird.

CURRENT SETUP:
Sony X940E / Denon AVR-S730h /
NVIDIA SHIELD TV 2017 / PANASONIC UB820 UHD PLAYER / MAudio BX8a front mains / Klipsch R‑15PM rear left/right / Emotiva C1 center / Polk Audio OWM3 height left/right.
Evan201 is offline  
post #8321 of 8463 Old 12-28-2018, 10:17 AM
Member
 
richardBEL's Avatar
 
Join Date: Apr 2014
Posts: 23
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Liked: 28
Apple TV 4K, Yamaha rxa760, Dolby vision

Hi,

I am about a quarter through the thread, so please forgive me if this question has been answered. Does anybody have a similar setup as in the title of my post and does Dolby vision work from the Apple TV through a Yamaha receiver to the 940E? The receiver hdmi through has been changed already and My current Samsung tv is recognized as hdr device by the Apple TV, but I wonder if it will recognize Dolby vision in this setup with the Sony?

940E should be delivered next week...

Thanks!
richardBEL is offline  
post #8322 of 8463 Old 12-28-2018, 10:29 AM
Senior Member
 
R8ders2K's Avatar
 
Join Date: Apr 2001
Location: Sunnyvale, CA, USA
Posts: 369
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 104 Post(s)
Liked: 89
@richardBEL

Just remember to have/get Certified Premium High Speed HDMI cables with the QR code sticker.
Attached Thumbnails
Click image for larger version

Name:	image.png
Views:	33
Size:	1.30 MB
ID:	2501914  

Sony XBR-75X940E
Onkyo TX-NR777
DIRECTV HS17 + C61K
Oppo UDP-203
TV 4K
R8ders2K is offline  
post #8323 of 8463 Old 12-28-2018, 11:52 AM
Senior Member
 
Evan201's Avatar
 
Join Date: Jan 2017
Posts: 410
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 268 Post(s)
Liked: 176
Quote:
Originally Posted by richardBEL View Post
Hi,

I am about a quarter through the thread, so please forgive me if this question has been answered. Does anybody have a similar setup as in the title of my post and does Dolby vision work from the Apple TV through a Yamaha receiver to the 940E? The receiver hdmi through has been changed already and My current Samsung tv is recognized as hdr device by the Apple TV, but I wonder if it will recognize Dolby vision in this setup with the Sony?

940E should be delivered next week...

Thanks!
Just guessing, but to pass DV I'm sure it will need to be enabled in the Apple TV 4k if not already, the receiver HDMI/video settings should be set to "enhanced" mode or something of the sort to allow for the wider bandwidth (could just be a specific hdmi input to go into on the back of the receiver), and the output HDMI from the receiver should be going into input number 2 or 3 only on the 940E (#3 has ARC support). You have to go into the HDMI settings of the 940E and set input 2 and 3 to "enhanced mode" also. Inputs 1 and 4 on the 940E will not do it. Make sure everything is completely up to date and current with firmware/software updates. Receiver/Apple/940E all need to be running the latest stuff so do that first. Samsung TV's don't support DV as you may know already.
I'm currently running dolby vision over HDMI into my 940E via native apps (VUDU) as well as my Panasonic UB820 blu-ray player (for Netflix). All my devices are going through my Denon S730h receiver which is set to enhanced HDMI mode and accepts ATMOS DTS:X like a dream. For most everything else other than DV content I'm using the Nvidia Shield TV which does HDR and ATMOS, but no Dolby Vision. Not sure if the Shield is even capable of a DV firmware update, but would sure love to see that happen. My cables are mostly Amazon Basics 3ft or 6ft HDMI 18gbps which do just fine for me. No drop outs of signal ever.

Here's something I found for you on the yamaha A760 owners thread.
http://afterconvert.com/forum/90-re...l#post56351900

CURRENT SETUP:
Sony X940E / Denon AVR-S730h /
NVIDIA SHIELD TV 2017 / PANASONIC UB820 UHD PLAYER / MAudio BX8a front mains / Klipsch R‑15PM rear left/right / Emotiva C1 center / Polk Audio OWM3 height left/right.

Last edited by Evan201; 12-28-2018 at 12:22 PM.
Evan201 is offline  
post #8324 of 8463 Old 12-28-2018, 01:50 PM
Advanced Member
 
ROMIL's Avatar
 
Join Date: Sep 2014
Posts: 677
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 506 Post(s)
Liked: 233
Quote:
Originally Posted by richardBEL View Post
Hi,



I am about a quarter through the thread, so please forgive me if this question has been answered. Does anybody have a similar setup as in the title of my post and does Dolby vision work from the Apple TV through a Yamaha receiver to the 940E? The receiver hdmi through has been changed already and My current Samsung tv is recognized as hdr device by the Apple TV, but I wonder if it will recognize Dolby vision in this setup with the Sony?



940E should be delivered next week...



Thanks!


As long as your Yamaha specifically supports DV, you should be good. Just need to make sure all three components are setup to actually push/receive DV. On the ATV 4K you need to make sure Match Range is turned on in order for the ATV to push DV thru the Yamaha to your 940E. You'll need to change some settings on the 940E when it arrives to push 4 K DV. Like someone already mentioned, make sure you have premium certified high speed HDMI cables throughout your setup.
ROMIL is online now  
post #8325 of 8463 Old 12-29-2018, 09:31 AM
Member
 
richardBEL's Avatar
 
Join Date: Apr 2014
Posts: 23
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Liked: 28
Thanks all for the detailed answers. I used the 760 thread to get the Samsung to show as hdr tv in the Apple TV a couple of weeks ago. Atmos works great too. Avsforum, and you guys of which it consists, ROCK!!!

I am so looking forward to that new tv...
richardBEL is offline  
post #8326 of 8463 Old 12-29-2018, 01:18 PM
Member
 
Join Date: Feb 2015
Posts: 96
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 129 Post(s)
Liked: 22
Quote:
Originally Posted by no_cure View Post
I was in the same boat only 2 weeks back: I chose the 940E for its stellar HT/dark room/movie capabilities. The blacks are BETTER than my Panny Plasma (still going strong), and haven't noticed any motion blur issues (I have my setting to SMOOTH).

Also, the 940E has a GAME setting as well, which will definitely help you when gaming...
Alright, so I finally broke. After debating more about this decision than my own mortality, I decided to cancel my 75 inch 900F order and replace it with the 75 inch 940E. The extra 28 degrees of black viewing angle and darker blacks convinced me, along with you, @Evan201 and others. Hoping I made the right choice and don't have any issues with motion trails on gaming. However based on everyone's comments, I feel like I'll be fine. The past 6 months on the LG C8 gave me great time to figure out my priorities and must have's. Knowing that this kills the 900F in every respect that I use it most for and for the exact same price seemed too hard to pass up in the end. Delivery for next sunday the 6th!

Side note, I noticed that the 940E has the best rating on...rtings for stutter. 9.8. Does this mean that 24p and 30p content is actually smoother on the 940E than the 900F? If the only motion "issues" are relegated to 60fps content, it seems like an actual benefit of the 940E. Or am I missing something?
MCaugusto, audiofan1 and Seryl like this.

Last edited by Ben Larkins; 12-29-2018 at 01:37 PM.
Ben Larkins is offline  
post #8327 of 8463 Old 12-29-2018, 02:26 PM
Member
 
Join Date: Apr 2018
Location: Plainfield NJ
Posts: 139
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 70 Post(s)
Liked: 50
24fps film, by design has stutter because of the low frame resolution. When you marry that with the slow response panel of the 940E, it gives the illusion of smoother motion. And that actually is a plus when watching 24fps film. With OLED, which has the fastest response, you need to use some motion smoothing to give the same appearance. It is easy to think that when they say "stutter", they are describing some kind of error in the reproduction. There is an example of this on the Rtings website. http://www.rtings.com/tv/tests/motion/stutter
kevin@KAB is online now  
post #8328 of 8463 Old 12-29-2018, 06:25 PM
Member
 
Join Date: Feb 2015
Posts: 96
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 129 Post(s)
Liked: 22
Thanks. The more time has gone by since my cancellation of the 900F and the order for the 940E, the more I get excited by this. Avoiding price specifics, I just can't believe how much of a steal this is at the big yellow and blue box. I think I've read all 278 pages of this thread and by in large it seems like the motion issues are non existent for those that actually own it. Really great to hear, and I can't freaking wait to get this sucker delivered. Coming from the C8 the viewing angle and blacks were my biggest disappointment to loose and it looks like pound for pound this seems to be the best way to go!
audiofan1, srkmish and Cam1977 like this.

Last edited by Ben Larkins; 12-29-2018 at 06:28 PM.
Ben Larkins is offline  
post #8329 of 8463 Old 12-29-2018, 06:30 PM
AVS Forum Special Member
 
Cam1977's Avatar
 
Join Date: Apr 2016
Location: El paso
Posts: 4,740
Mentioned: 28 Post(s)
Tagged: 0 Thread(s)
Quoted: 2597 Post(s)
Liked: 2917
^you will be very happy with your purchase!
Cam1977 is offline  
post #8330 of 8463 Old 12-29-2018, 09:06 PM
AVS Forum Addicted Member
 
chunon's Avatar
 
Join Date: Dec 2007
Location: Cincinnati Ohio
Posts: 10,628
Mentioned: 33 Post(s)
Tagged: 0 Thread(s)
Quoted: 3347 Post(s)
Liked: 3029
Quote:
Originally Posted by Ben Larkins View Post
Thanks. The more time has gone by since my cancellation of the 900F and the order for the 940E, the more I get excited by this. Avoiding price specifics, I just can't believe how much of a steal this is at the big yellow and blue box. I think I've read all 278 pages of this thread and by in large it seems like the motion issues are non existent for those that actually own it. Really great to hear, and I can't freaking wait to get this sucker delivered. Coming from the C8 the viewing angle and blacks were my biggest disappointment to loose and it looks like pound for pound this seems to be the best way to go!


As a previous owner that went from Oled to the 940e I think you will be pleased , the dimming is excellent and the blacks are very deep by lcd standards . This set was a hidden gem that didn’t get the accolades it deserves imo


Sent from my iPhone using Tapatalk
mnc, audiofan1, srkmish and 1 others like this.

Sony XBR 65A8F calibrated by Chad_B
LG 55B7A
DirectTV/ ATV4k/Panasonic UB820/Sony Z9F Soundbar
chunon is online now  
post #8331 of 8463 Old 12-29-2018, 09:23 PM
Member
 
Join Date: Feb 2017
Posts: 43
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 47 Post(s)
Liked: 13
Today is a very sad day. I was watching my TV and noticed a thin blue line going from top to bottom. After closer inspection, there seems to be a small ding by the edge of the screen. I'm hoping this can be resolved without replacing the panel. Any way to fix the issue? If not, can the panel be replaced or do I have to replace the unit?
Attached Thumbnails
Click image for larger version

Name:	IMG_20181227_134522.jpg
Views:	82
Size:	2.83 MB
ID:	2502608   Click image for larger version

Name:	IMG_20181227_134515.jpg
Views:	58
Size:	1,005.3 KB
ID:	2502610  

Video: Sony XBR75X940E
Audio: Pioneer Elite VSX-LX301 -> Klipsch 5.1.2 | RP-250F | RP-250C | RP-150M | RP-140SA | R-112SW
Inputs: Apple TV 4k | Oppo UDP-203 | Sony Playstation 4 Pro | Sony Playstation 3 | Nintendo Switch
Drew Ski is offline  
post #8332 of 8463 Old 12-29-2018, 09:26 PM
AVS Forum Special Member
 
Cam1977's Avatar
 
Join Date: Apr 2016
Location: El paso
Posts: 4,740
Mentioned: 28 Post(s)
Tagged: 0 Thread(s)
Quoted: 2597 Post(s)
Liked: 2917
^oh no...have you tried a factory reset?
Cam1977 is offline  
post #8333 of 8463 Old 12-29-2018, 09:37 PM
Member
 
Join Date: Feb 2017
Posts: 43
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 47 Post(s)
Liked: 13
Quote:
Originally Posted by Cam1977 View Post
^oh no...have you tried a factory reset?
Yeah, that did not work either.

Video: Sony XBR75X940E
Audio: Pioneer Elite VSX-LX301 -> Klipsch 5.1.2 | RP-250F | RP-250C | RP-150M | RP-140SA | R-112SW
Inputs: Apple TV 4k | Oppo UDP-203 | Sony Playstation 4 Pro | Sony Playstation 3 | Nintendo Switch
Drew Ski is offline  
post #8334 of 8463 Old 12-29-2018, 09:46 PM
AVS Forum Special Member
 
Cam1977's Avatar
 
Join Date: Apr 2016
Location: El paso
Posts: 4,740
Mentioned: 28 Post(s)
Tagged: 0 Thread(s)
Quoted: 2597 Post(s)
Liked: 2917
^oh ok...I would call Sony especially if your under warranty.
Cam1977 is offline  
post #8335 of 8463 Old 12-29-2018, 11:46 PM
Member
 
Join Date: Feb 2017
Posts: 43
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 47 Post(s)
Liked: 13
Quote:
Originally Posted by Cam1977 View Post
^oh ok...I would call Sony especially if your under warranty.
Unfortunately, I am 20 days past the one year mark. They denied my claim.

Video: Sony XBR75X940E
Audio: Pioneer Elite VSX-LX301 -> Klipsch 5.1.2 | RP-250F | RP-250C | RP-150M | RP-140SA | R-112SW
Inputs: Apple TV 4k | Oppo UDP-203 | Sony Playstation 4 Pro | Sony Playstation 3 | Nintendo Switch
Drew Ski is offline  
post #8336 of 8463 Old 12-30-2018, 05:43 AM
AVS Forum Special Member
 
oldcband's Avatar
 
Join Date: May 2005
Location: Big thinkers
Posts: 5,554
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 1540 Post(s)
Liked: 1258
So sorry to hear about issues.

When I bought mine I was going to cover all my bases. BB delivered, mounted and set-up and I bought there over priced 5 yr warranty.

BB will try to fix any problem several times and if they can't will refund your money you paid.

Knock on wood nothing will ever come about.

I love this TV.
MCaugusto likes this.

These are just my opinions.
oldcband is offline  
post #8337 of 8463 Old 12-30-2018, 07:57 AM
Member
 
Join Date: Apr 2018
Location: Plainfield NJ
Posts: 139
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 70 Post(s)
Liked: 50
Quote:
Originally Posted by Drew Ski View Post
Unfortunately, I am 20 days past the one year mark. They denied my claim.
Did you buy it with a major credit card? Check for extended warranty through them. Was this "ding" something new or was it always there?
kevin@KAB is online now  
post #8338 of 8463 Old 12-30-2018, 08:01 AM
AVS Forum Special Member
 
audiofan1's Avatar
 
Join Date: Feb 2009
Posts: 6,536
Mentioned: 14 Post(s)
Tagged: 0 Thread(s)
Quoted: 2221 Post(s)
Liked: 2628
Quote:
Originally Posted by Drew Ski View Post
Unfortunately, I am 20 days past the one year mark. They denied my claim.
Try again
audiofan1 is offline  
post #8339 of 8463 Old 12-30-2018, 09:21 AM
Member
 
Join Date: Feb 2017
Posts: 43
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 47 Post(s)
Liked: 13
Quote:
Originally Posted by oldcband View Post
So sorry to hear about issues.

When I bought mine I was going to cover all my bases. BB delivered, mounted and set-up and I bought there over priced 5 yr warranty.

BB will try to fix any problem several times and if they can't will refund your money you paid.

Knock on wood nothing will ever come about.

I love this TV.
Seriously, one of the best TVs I've owned. I purchased the TV from PC Richards in NY. The extended warranty was around 700 bucks. Should have done it...

Quote:
Originally Posted by kevin@KAB View Post
Did you buy it with a major credit card? Check for extended warranty through them. Was this "ding" something new or was it always there?
I financed it through a store card. So, if you don't purchase their warranty you are out of luck. Going to use my Visa next time for major purchases like this. The ding is new.

Quote:
Originally Posted by audiofan1 View Post
Try again
Is it really just who you get on the line?

Video: Sony XBR75X940E
Audio: Pioneer Elite VSX-LX301 -> Klipsch 5.1.2 | RP-250F | RP-250C | RP-150M | RP-140SA | R-112SW
Inputs: Apple TV 4k | Oppo UDP-203 | Sony Playstation 4 Pro | Sony Playstation 3 | Nintendo Switch

Last edited by Drew Ski; 12-30-2018 at 09:37 AM.
Drew Ski is offline  
post #8340 of 8463 Old 12-30-2018, 01:58 PM
AVS Forum Special Member
 
oldcband's Avatar
 
Join Date: May 2005
Location: Big thinkers
Posts: 5,554
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 1540 Post(s)
Liked: 1258
^^^
Keep after them the squeaky wheel gets the grease.
audiofan1 likes this.

These are just my opinions.
oldcband is offline  
Sponsored Links
Advertisement
 
Reply LCD Flat Panel Displays

Tags
signal loss



Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off